[Libusbx-devel] why not support hotplug usb ?

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Libusbx-devel] why not support hotplug usb ?

Nothing
I use libusb1.0.18 but  libusb_has_capability () return false ?

the attach file is the source file of linux   please give me some help ,thanks very much 

------------------------------------------------------------------------------
Android apps run on BlackBerry 10
Introducing the new BlackBerry 10.2.1 Runtime for Android apps.
Now with support for Jelly Bean, Bluetooth, Mapview and more.
Get your Android app in front of a whole new audience.  Start now.
http://pubads.g.doubleclick.net/gampad/clk?id=124407151&iu=/4140/ostg.clktrk
_______________________________________________
libusbx-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/libusbx-devel

libusbtest.tar.gz (466K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Libusbx-devel] why not support hotplug usb ?

Xiaofan Chen
On Wed, Feb 12, 2014 at 10:09 AM, Nothing <[hidden email]> wrote:
> I use libusb1.0.18 but  libusb_has_capability () return false ?
>
> the attach file is the source file of linux   please give me some help
> ,thanks very much
>

Please do not attach libusb binaries. They are totally useless for
others.

Please tell us more details. What is the OS you are using?
How do you build libusb-1.0.18?

If your platform does not support Hotplug or you have disabled
hotplug during the building, then hotplug capability will be false.


--
Xiaofan

------------------------------------------------------------------------------
Android apps run on BlackBerry 10
Introducing the new BlackBerry 10.2.1 Runtime for Android apps.
Now with support for Jelly Bean, Bluetooth, Mapview and more.
Get your Android app in front of a whole new audience.  Start now.
http://pubads.g.doubleclick.net/gampad/clk?id=124407151&iu=/4140/ostg.clktrk
_______________________________________________
libusbx-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/libusbx-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Libusbx-devel] why not support hotplug usb ?

Nothing
I use ubuntu 13.04  i build it use ./configure      then  make  install


------------------ Original ------------------
From:  "Xiaofan Chen";<[hidden email]>;
Date:  Wed, Feb 12, 2014 11:02 AM
To:  "libusbx-devel"<[hidden email]>;
Subject:  Re: [Libusbx-devel] why not support hotplug usb ?

On Wed, Feb 12, 2014 at 10:09 AM, Nothing <[hidden email]> wrote:
> I use libusb1.0.18 but  libusb_has_capability () return false ?
>
> the attach file is the source file of linux   please give me some help
> ,thanks very much
>

Please do not attach libusb binaries. They are totally useless for
others.

Please tell us more details. What is the OS you are using?
How do you build libusb-1.0.18?

If your platform does not support Hotplug or you have disabled
hotplug during the building, then hotplug capability will be false.


--
Xiaofan

------------------------------------------------------------------------------
Android apps run on BlackBerry 10
Introducing the new BlackBerry 10.2.1 Runtime for Android apps.
Now with support for Jelly Bean, Bluetooth, Mapview and more.
Get your Android app in front of a whole new audience.  Start now.
http://pubads.g.doubleclick.net/gampad/clk?id=124407151&iu=/4140/ostg.clktrk
_______________________________________________
libusbx-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/libusbx-devel
.

------------------------------------------------------------------------------
Android apps run on BlackBerry 10
Introducing the new BlackBerry 10.2.1 Runtime for Android apps.
Now with support for Jelly Bean, Bluetooth, Mapview and more.
Get your Android app in front of a whole new audience.  Start now.
http://pubads.g.doubleclick.net/gampad/clk?id=124407151&iu=/4140/ostg.clktrk
_______________________________________________
libusbx-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/libusbx-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Libusbx-devel] why not support hotplug usb ?

Xiaofan Chen
On Wed, Feb 12, 2014 at 1:13 PM, Nothing <[hidden email]> wrote:
> I use ubuntu 13.04  i build it use ./configure      then  make  install
>

What is the architecture? Is it x86/x64 or ARM? You may
want to post all the build log.



--
Xiaofan

------------------------------------------------------------------------------
Android apps run on BlackBerry 10
Introducing the new BlackBerry 10.2.1 Runtime for Android apps.
Now with support for Jelly Bean, Bluetooth, Mapview and more.
Get your Android app in front of a whole new audience.  Start now.
http://pubads.g.doubleclick.net/gampad/clk?id=124407151&iu=/4140/ostg.clktrk
_______________________________________________
libusbx-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/libusbx-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Libusbx-devel] why not support hotplug usb ?

Chris Dickens
The linker is linking against your system's libusb at runtime instead of your compiled one. You have two options:

1) Tell the linker to link against your libusb by using the following line in the Makefile:
$(CC) $(CFLAGS) -g -o zinFrameLinuxV6 $(SRC) -L./ -lusb-1.0 -Wl,-rpath,.
2) Set LD_LIBRARY_PATH to the directory containing your compiled library
LD_LIBRARY_PATH=. ./zinFrameLinuxV6

Chris


On Wed, Feb 12, 2014 at 1:25 AM, Xiaofan Chen <[hidden email]> wrote:
On Wed, Feb 12, 2014 at 1:13 PM, Nothing <[hidden email]> wrote:
> I use ubuntu 13.04  i build it use ./configure      then  make  install
>

What is the architecture? Is it x86/x64 or ARM? You may
want to post all the build log.



--
Xiaofan

------------------------------------------------------------------------------
Android apps run on BlackBerry 10
Introducing the new BlackBerry 10.2.1 Runtime for Android apps.
Now with support for Jelly Bean, Bluetooth, Mapview and more.
Get your Android app in front of a whole new audience.  Start now.
http://pubads.g.doubleclick.net/gampad/clk?id=124407151&iu=/4140/ostg.clktrk
_______________________________________________
libusbx-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/libusbx-devel


------------------------------------------------------------------------------
Android apps run on BlackBerry 10
Introducing the new BlackBerry 10.2.1 Runtime for Android apps.
Now with support for Jelly Bean, Bluetooth, Mapview and more.
Get your Android app in front of a whole new audience.  Start now.
http://pubads.g.doubleclick.net/gampad/clk?id=124407151&iu=/4140/ostg.clktrk
_______________________________________________
libusbx-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/libusbx-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Libusbx-devel] why not support hotplug usb ?

Nothing
In reply to this post by Nothing
tks very much it works 

------------------ Original ------------------
From:  "Chris Dickens";<[hidden email]>;
Date:  Thu, Feb 13, 2014 06:18 AM
To:  "libusbx-devel"<[hidden email]>;
Subject:  Re: [Libusbx-devel] why not support hotplug usb ?

The linker is linking against your system's libusb at runtime instead of your compiled one. You have two options:

1) Tell the linker to link against your libusb by using the following line in the Makefile:
$(CC) $(CFLAGS) -g -o zinFrameLinuxV6 $(SRC) -L./ -lusb-1.0 -Wl,-rpath,.
2) Set LD_LIBRARY_PATH to the directory containing your compiled library
LD_LIBRARY_PATH=. ./zinFrameLinuxV6

Chris


On Wed, Feb 12, 2014 at 1:25 AM, Xiaofan Chen <[hidden email]> wrote:
On Wed, Feb 12, 2014 at 1:13 PM, Nothing <[hidden email]> wrote:
> I use ubuntu 13.04 i build it use ./configure then make install
>

What is the architecture? Is it x86/x64 or ARM? You may
want to post all the build log.



--
Xiaofan

------------------------------------------------------------------------------
Android apps run on BlackBerry 10
Introducing the new BlackBerry 10.2.1 Runtime for Android apps.
Now with support for Jelly Bean, Bluetooth, Mapview and more.
Get your Android app in front of a whole new audience. Start now.
http://pubads.g.doubleclick.net/gampad/clk?id=124407151&iu=/4140/ostg.clktrk
_______________________________________________
libusbx-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/libusbx-devel


------------------------------------------------------------------------------
Android apps run on BlackBerry 10
Introducing the new BlackBerry 10.2.1 Runtime for Android apps.
Now with support for Jelly Bean, Bluetooth, Mapview and more.
Get your Android app in front of a whole new audience.  Start now.
http://pubads.g.doubleclick.net/gampad/clk?id=124407151&iu=/4140/ostg.clktrk
_______________________________________________
libusbx-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/libusbx-devel
Loading...