[Libusbx-devel] Compiling the libu

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Libusbx-devel] Compiling the libu

Pradeepa Senanayake-2
Hello,

We have a product which uses freescale iMX6 processor and the following Linux BSP version.

root@freescale ~$ uname -a
Linux freescale 3.0.35-2666-gbdde708 #18 SMP PREEMPT Tue Sep 1 15:17:34 IST 2015 armv7l GNU/Linux

We are trying to install the latest libusbx package (1.0.18) to our system. But we found out that there is a dependency for libudev. Since that lib is not available in our current BSP we cannot install libusbx at the moment. 

But we can install libusb 1.0.15 (which too has an issue which I will post separately). Is there anyway we can disable the libudev dependency using configure options and build the libusbx-1.0.18 package? Is the change from 1.0.15 to 1.0.18 substantial?

Thank you.
-Pradeepa

------------------------------------------------------------------------------
Monitor Your Dynamic Infrastructure at Any Scale With Datadog!
Get real-time metrics from all of your servers, apps and tools
in one place.
SourceForge users - Click here to start your Free Trial of Datadog now!
http://pubads.g.doubleclick.net/gampad/clk?id=241902991&iu=/4140
_______________________________________________
libusbx-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/libusbx-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Libusbx-devel] Compiling the libu

Chris Dickens
Hi,

On Wed, Sep 2, 2015 at 9:14 PM, Pradeepa Senanayake <[hidden email]> wrote:
We are trying to install the latest libusbx package (1.0.18) to our system. But we found out that there is a dependency for libudev. Since that lib is not available in our current BSP we cannot install libusbx at the moment. 

But we can install libusb 1.0.15 (which too has an issue which I will post separately). Is there anyway we can disable the libudev dependency using configure options and build the libusbx-1.0.18 package? Is the change from 1.0.15 to 1.0.18 substantial?

libusb versions 1.0.16 and later require at least netlink support on Linux. You can pass configure the '--disable-udev' flag to select netlink instead.

There have been many changes from v1.0.15 to v1.0.18. The latest (libusb) is now v1.0.20-rc2. I encourage you to try that.

For future issues, please use the libusb-devel mailing list instead of libusbx-devel. libusbx is now obsolete.

Regards,
Chris

------------------------------------------------------------------------------
Monitor Your Dynamic Infrastructure at Any Scale With Datadog!
Get real-time metrics from all of your servers, apps and tools
in one place.
SourceForge users - Click here to start your Free Trial of Datadog now!
http://pubads.g.doubleclick.net/gampad/clk?id=241902991&iu=/4140
_______________________________________________
libusbx-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/libusbx-devel
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [Libusbx-devel] Compiling the libu

Pradeepa Senanayake
Hello Chris,

Thank you for the suggestion. We compiled libusb-1.0.19 using --disable-udev option on our device. It works well. 



Best Regards,
Pradeepa Senanayake.

On Thu, Sep 3, 2015 at 10:22 AM, Chris Dickens <[hidden email]> wrote:
Hi,

On Wed, Sep 2, 2015 at 9:14 PM, Pradeepa Senanayake <[hidden email]> wrote:
We are trying to install the latest libusbx package (1.0.18) to our system. But we found out that there is a dependency for libudev. Since that lib is not available in our current BSP we cannot install libusbx at the moment. 

But we can install libusb 1.0.15 (which too has an issue which I will post separately). Is there anyway we can disable the libudev dependency using configure options and build the libusbx-1.0.18 package? Is the change from 1.0.15 to 1.0.18 substantial?

libusb versions 1.0.16 and later require at least netlink support on Linux. You can pass configure the '--disable-udev' flag to select netlink instead.

There have been many changes from v1.0.15 to v1.0.18. The latest (libusb) is now v1.0.20-rc2. I encourage you to try that.

For future issues, please use the libusb-devel mailing list instead of libusbx-devel. libusbx is now obsolete.

Regards,
Chris

------------------------------------------------------------------------------
Monitor Your Dynamic Infrastructure at Any Scale With Datadog!
Get real-time metrics from all of your servers, apps and tools
in one place.
SourceForge users - Click here to start your Free Trial of Datadog now!
http://pubads.g.doubleclick.net/gampad/clk?id=241902991&iu=/4140
_______________________________________________
libusbx-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/libusbx-devel



------------------------------------------------------------------------------

_______________________________________________
libusbx-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/libusbx-devel
Loading...